D5100 "This memory card cannot be used"

Started Mar 1, 2013 | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
M J B
New MemberPosts: 4
Like?
D5100 "This memory card cannot be used"
Mar 1, 2013

So, today, after transferring images from my SanDisk 1GB SD card to the computer, via a card reader, I erroneously hit "Delete" and wiped the card before returning it to my D5100. (I didn't know this was a problem at the time.) Once back in the D5100, I promptly formatted the card in the camera, as I had intended and then tried to take a couple shots (the format completed successfully, or at least without any errors being reported). To my surprise, when the camera tried to write the shots from the buffer to the card, I got: "This memory card cannot be used. Card may be damaged. Insert another card."

I've done a fair bit of Google-ing, but the what I've found either says "format the card", update firmware (I'm at A 1.01, B 1.01, and L 1.006), or the situation is one where the SD card itself has failed. As to those scores:

+Card failure is not the case here--I've done numerous read/write/copies/what-have-you on the card via the reader on my computer. I have sucessfully taken shots on the card with my old, old point-and-shoot (a Canon PowerShot A510).

+Firmware is up-to-date, according to the camera menus and the info I can find on Nikon's site.

+I've repeatedly, and allegedly successfully, formatted the card on the D5100. I've removed the card and the battery from the D5100 and tried again. But, after everything, the moment I take a shot with the D5100 and it tries to write from buffer to card, I receive the "This memory card cannot be used. Card may be damaged. Insert another card."

I cannot believe that simply because I wiped the card, rather than leaving the pics intact and then formatting, the D5100 refuses to ever use it again...else how could it ever use a new card? Granted, the card is old, but it still was working fine in the D5100 until I took the images off it, and continues to work fine with the PC and in the old Canon P&S.

Is there something I've failed to try?

Any help would be appreciated!

ANSWER:
Nikon D5100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow