One Lens Works and One Does Not

Started Feb 7, 2013 | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
SheriLynn512
New MemberPosts: 1
Like?
One Lens Works and One Does Not
Feb 7, 2013

I am having a problem with my Canon EOS Rebel 1100D. I was attempting to take pictures in a large room with low light - I had it set on MANUAL and noticed that the pictures were coming out extremely dark, even with the flash. I changed it to AUTOFOCUS and it would not take the picture. It seems to be stuck in a continuous state of trying to focus. I took the lens off and a rather small black piece, with gold prongs fell out of the camera. However, when I changed lenses to my zoom, the pictures came out perfect.

I don't know if it's a problem with the lens or the camera. I'm trying to figure out if it makes more sense to buy a new lens for everyday use or if my camera needs repairing. I hope I've explained the problem - it has me stumped. Especially because I can't see anywhere that looks like this piece came out of.

ANSWER:
This question has not been answered yet.
Canon EOS 1000D (EOS Rebel XS / Kiss F Digital) Canon EOS 1100D (EOS Rebel T3 / EOS Kiss X50)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow