55mm 1.7 Minolta MC Rokkor-PF on NEX-5r Apertur not working

Started Feb 5, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
KingCharles
Regular MemberPosts: 150
Like?
55mm 1.7 Minolta MC Rokkor-PF on NEX-5r Apertur not working
Feb 5, 2013

So I have the MD-NEX adapter from rainbowimaging, and just got this lens. This is my first old MC/MD lens so I wanted to know if this action is normal.

Basically the aperture ring doesn't do anything unless you take the lens off an push the "stem" in a counter clockwise direction. When you do this the aperture stops down to the width noted on the ring. If you stop back up using the ring at this point the aperture will open up.

Other people have noted these lenses should work with just the ring, and there is no need to play with the stem. This makes me think the aperture ring is missing a connection when stopping down, but is pushing correctly when going back up.

Any thoughts on this? This was an ebay buy, and I got it for $20 so I am thinking I may just take it to a local store and have them fix it if possible. Or does this sound like something unfixable that I should put a complaint in for?

Thanks for any info you can give.

NEX5R
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow