NEX-6 odd behaviors (18-55 and Sigma lenses)

Started Jan 26, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
thetodd34
Regular MemberPosts: 104
Like?
NEX-6 odd behaviors (18-55 and Sigma lenses)
Jan 26, 2013

just curious if anyone has explanations for these occurrences. i'm not really interested in "nope, doesn't happen to mine. send it back to sony for service." i just sent it in for another reason, but mentioned these issues, and they found nothing wrong. i think it's just "electronic glitches" related to an E-mount, but what do i know?

1) when i attach a sony 18-55 kit lens, every once in a while, while shooting, the screen will go dark -- not completely black, just dark -- and then take about 2 seconds and then everything is back to normal and i can keep shooting. the camera doesn't shut down, but i can't take any pictures when it's doing the dark thing. i've not noticed this on any of my other lenses (16-50pz, sigma 19/30, sel 50). i guess this could be a problem with the 18-55 lens itself, but that's ok, it's a cheap lens that's just holding me over until the higher quality standard zoom is released.

2) i've noticed when shooting with both my sigma 19 and sigma 30 lenses, that every once in a while, randomly, the camera will be set on a very short macro focal point. if i point at something farther away and half-press the shutter, the camera seems to try to focus, but everything is blurry, and if i point the camera at something close to the lens (like less than 1 foot away), i can tell that it has a very short focal distance, and it is in fact in focus at that point. with the camera on, i've switched from AF, to MF, to DMF, and switched AF area (center, select, multi) -- and nothing can wake the camera out of this daze. simply turning the camera off/on fixes it. any ideas?

3) every once in a while when i'm in playback mode, viewing pictures, the camera will revert back to active shooting mode (ie. kick me out of playback), even without me pressing anything. i've seen this behavior with both sony and sigma lenses. any ideas?

i'm not complaining, and like i said, i'm not looking for input telling me to send everything back to sony. the nex-6 has helped me take some great pictures of my family. these problems do not happen all the time, they do not happen every day. just curious. i'm just trying to take an intellectual approach to this and see if anyone has any ideas.

thanks!

Sony Alpha NEX-6
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow