FT 50-200 mkI is always off focus with OM-D

Started Jan 19, 2013 | Discussions thread
Mister H
Regular MemberPosts: 213Gear list
Like?
Re: FT 50-200 mkI is always off focus with OM-D
In reply to sparklite, Jan 23, 2013

sparklite wrote:

Does anyone else have problems with AF on the OM-D with the FT Zuiko 50-200mm f2.8-3.5 Mk I? It occasionally missess focus all together (ok, i'll accept that since it is an MFT lens) but when it gets a focus "lock" it is still out of focus. I have to manually focus VERY gently about two or three "clicks" to get it pin sharp.

What might cause this? i'm using OLY adaptors.

My experience matches yours. I too have the non-SWD version, it's one of my favourite lenses on my E-3 but a massive disappointment on my E-M5. It was very slow and hesitant to focus and often mis-focussed. I took it for a wildlife walk in Florida not long after buying my E-M5 and only had a handful of OK shots of slow moving or stationary wading birds. After that I tried the m43 Olympus 75-300mm lens and was extremely impressed - massively easier to handle, fast & accurate focussing, and very sharp.

-- hide signature --

I'm getting there...

 Mister H's gear list:Mister H's gear list
Olympus E-3 Olympus PEN E-P3 Olympus E-M1 Olympus Zuiko Digital ED 50mm 1:2.0 Macro Olympus M.Zuiko Digital ED 9-18mm 1:4.0-5.6 +15 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow