A couple months with the XE-1

Started Jan 2, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
AngDaga
New MemberPosts: 16
Like?
A couple months with the XE-1
Jan 2, 2013

I've had the XE-1 for a month or two now and thought I would give an update for those still on the fence. My initial review was glowing, and now that I've used it extensively, these are a couple updates:

High ISO is amazing! Seriously. See this picture of my son taken at 6400.

I couldn't have got this shot with my Canon Rebel T21. I need to print this out 8x10 or larger just to see how it looks.  However, I almost couldn't get this due to the poor low light auto focus abilities of the camera. This is so frustrating. In good light, it can be a tad slow and I can live with that, but sometimes I have to try multiple times  just to lock on in low light situations.

Another negative i mentioned before, but it's driving me nuts. I don't like to exclusively use the center point autofocus point, and recompose, especially if using larger apertures. To change to point is so cumbersome.  I'm not sure how Fujifilm could fix this, but it's so annoying and time consuming.

Also, the processor seems to be a little underpowered. To navigate menus, review photos, etc is really slow.

Anyways, despite the negatives, I still love this camera. I'm taking it out so much more than I even did with my DSLR. The glass combined with the imaging sensor produce some fantastic photos. The poor SLR is still sitting on the shelf.

Sony Cyber-shot DSC-T2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow