D600 OIL/DUST Report at 12,720 Shutter Count

Started Jan 2, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Nikonfan99
Senior MemberPosts: 1,411Gear list
Like?
D600 OIL/DUST Report at 12,720 Shutter Count
Jan 2, 2013

So here is an update to my D600 dust/oil issue. The sensor was wet cleaned again just a few days ago. This was at 10,723 shutter count.

Here is the sensor after the wet cleaning.





Here is the sensor 1,997 test shots later:



As you can see how much oil/dust was added to the sensor right after a cleaning. The lens was never removed after the cleaning. Camera stayed in bag and only removed to do test shots inside. You can see one large spot at even f5.6 with another faint spot, AT f8 it shows worst and at f16 it is pretty bad. I ordered a sensor blower kit from american recorder and will blow out the camera once I get it and do further testing. The american recorder c02 kit says it has no lubricants and is designed for sensors from what I read. My main issue seems to be oil so I dont think the air blower kit will do much.





 Nikonfan99's gear list:Nikonfan99's gear list
Canon EOS 6D Canon EF 100mm f/2.8L Macro IS USM Canon EF 40mm f/2.8 STM
Nikon D600 Panasonic Lumix DMC-F5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow