RX1 battery drain issue?

Started Dec 27, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
zgeist
Junior MemberPosts: 47
Like?
RX1 battery drain issue?
Dec 27, 2012

Just got my RX1 a few days ago and have just discovered a potential battery problem.  In addition to the stock OEM battery, I got an external charger that included two batteries (Wasabi Power).  I used the OEM battery for the first couple of days.  The last I checked (two nights ago), the battery was at least 2/3 full.  Then yesterday morning, I was showing my work colleague the camera and when I tried to turn it on, it was dead.  The ON/OFF switch was off.  So I simply switched to one of the other batteries.  Camera turned on, battery was full, great.   I took a couple of snapshots at work and that was it.

This morning, I woke up to a beautiful sunrise so I pulled out the camera to take a shot.  As soon as I turned it on, I was greeted with a message, "Battery Depleted" and it died.  So then I switched to the third battery and it works fine, for now.  I'm waiting to see what happens to the battery tonight.  And yes, I have triple checked to make sure the camera is off.  In total, I have less than 150 shots.

Anyone else encountering any battery issues?

Sony RX1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow