Ink Republic CIS nightmare!

Started Dec 24, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Robert Hoy
Senior MemberPosts: 1,568
Like?
Ink Republic CIS nightmare!
Dec 24, 2012

I got an Ink Republic CIS for my 6 year old Epson R1800 and what a mess.  Clogs, clogs, clogs!

First the instructions are 7 years old and are outdated showing and detailing items that are now not part of their system.  And their instructions seem to be poorly translated into English from another lanugage.  I had to search the internet looking fo images of a finished recent R1800 system to figure out how to attach the tube brackets since what was pictured in their instructions weren't even close to the brackets they shipped me.  Alass, I've dumped about 15% of my large bottles of ink already through cleaning cycles trying to get all nozzles to print with no avail.

I just got a nozzle test pattern print out to be as close to being "good" as I've had so far and just did another head cleaning and guess what?  It made it worse!  And of course I never had any problems using Epson ink cartridges.  Initially my Blue ink was not printing much at all, so I pulled its damper out and used the print head cleaning kit they shipped me with their system.  And that made the Photo Black and Red ink go from nearly perfect to 50% printing on the nozzle pattern test.

And whenever the print heads move all the way to the left of the printer, there's a bad gear grinding noise that now happens that again never happened before.

Any thoughts before I pull all their crap out of my printer and go back to Epson tanks?  Thanks!



ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow