Auto exposure with full manual lenses, why not?

Started Dec 24, 2012 | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
Eric Perez
Regular MemberPosts: 110
Like?
Auto exposure with full manual lenses, why not?
Dec 24, 2012

I have a fairly affordable 50mm 1.7 full manual prime. No A setting on the aperture ring, no AF, full manual. I notice that the only time I can set my aperture of course, is in M-mode in camera, using the green button to set appropriate shutter speed. If I am in TAV or the others, it forces me to shoot wide open in order to get auto exposure. The thing is, when I am in video mode, I can both choose the aperture I want with my aperture ring and get auto exposure (I assume it is adjusting both shutter speed and iso although I cannot see them on my K5). So why can the camera do this when shooting video but not in the former?

Is it a LV thing? If so will I get both if shooting photos in LV (haven't tried it actually, never shoot photos in LV really)? It seems odd that they can allow it in video, but not for stills. Am I missing something? Also, will this lock happen if my lens is attached through an adapter, such as an extension tube? I assume it is some kind of lever in the mount that locks the lens wide open, because I can only use exposure preview when in M mode.

ANSWER:
Pentax K-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow