Very disappointed with Canon T4i (650D) - over-exposed/washed out pictures

Started Dec 10, 2012 | Discussions thread
WilbaW
Veteran MemberPosts: 8,201Gear list
Like?
Re: Very disappointed with Canon T4i (650D) - over-exposed/washed out pictures
In reply to karl mohr, Dec 11, 2012

karl mohr wrote:

WilbaW wrote:

karl mohr wrote:

Even with ALO turned off I think most Rebels - including my T4i, seem to overexpose a little. In very bright sunlight I usually have to dial down the EC a little to get the type of exposure I'm looking for. So basically, I have to monitor the LCD after taking pictures to make sure I'm getting what I want. And looking at the histogram as well. I've even noticed this with my T2i and my Xti to some degree.

That's the way photography works with reflectance metering. The meters in your cameras are not incompetent or faulty. They are functioning perfectly by providing information for you to do what you described, and you have to do that to get the image brightness you want. The problem is the expectation that the meter should always know what you what you want and do it for you.

Agreed, and sometimes the captured image could probably be more accurate exposure-wise than we think - it's just that most people probably like their image with more saturation and richer colors.

Mm, you could say a good image is one you like. (Is there more to it than that?) 

Having said that, I have noticed when out photographing with friends that own 60Ds that they seem to get a nicer picture when standing side-by-side photographing the same subject. Just my 2 cents...

Yeah, I'm sure my 450D took more work to get what I wanted.

-- hide signature --

Check out the unofficial Rebel Talk FAQ - http://snipurl.com/RebelFAQ

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
imqqmi MOD
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow