Senor cleaning mode on Nex-6 is weak?

Started Nov 30, 2012 | Discussions thread
The Lotus Eater
Regular MemberPosts: 321Gear list
Like?
Re: Senor cleaning mode on Nex-6 is weak?
In reply to illiterate, Dec 1, 2012

illiterate wrote:

Hi. I own both the original NEX-5 and the new NEX-6, and I have couple lens as well so I change lens from time to time.

When I have dust problem on NEX-5, using the camera's cleaning mode and a blower always take care of the problem. But on NEX-6, the cleaning mode seems very weak, and I cannot remove the dust just with a blower anymore after using the cleaning mode.

On NEX-5, right after triggering the sensor cleaning mode, there is a tangible vibration on the camera and a sound that is loud enough for me to hear with the camera a few feet away from my ears. But on NEX-6, I don't feel the camera vibrate, and the only sound that come out from the camear is a very high pitch that is so weak that I can only hear with the camear pressing against my ears.

Is it normal? Does Sony dial down the strength of NEX's sensor cleaning mode after the original NEX-5?

I have to say I've never felt any vibration from my NEX-5 when running the cleaning mode.  It doesn't seem to do anything like my A700, which does a high frequency vibration when running the cleaning mode.

To be honest, I've never seen either camera shake dust off on their own.  It always has to be followed up with a rocket blower, and that often doesn't work either.

 The Lotus Eater's gear list:The Lotus Eater's gear list
Sony Alpha DSLR-A700 Sony SLT-A77 Sony Alpha NEX-6 Sony Alpha 7 Sigma 10-20mm F4-5.6 EX DC HSM +8 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow