t3i (600D) Meike battery grip having trouble with AAs

Started Nov 22, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
BobtheMagicMoose
New MemberPosts: 8
Like?
t3i (600D) Meike battery grip having trouble with AAs
Nov 22, 2012

I have had my Meike battery grip  for a bit over a year and just now am trying out AAs in it. I got it just for the added size so the camera would fit better in my hand. I am considering getting a batch of rechargeable AAs for my flash and it would be nice if they would work in the camera as well, but I notice that with some slightly used Duracells the camera flashes like it is about to go dead. If I swap a couple Duracells for cheap-o $1 batteries the camera won't even turn on. With the Duracells I get 8.6V (6 in the cartridge, the batteries are a titch used).

So I guess I'm wondering, is my battery grip defective or is this normal? I also worry that getting a bunch of NiMH rechargeables will be insufficient because they only will put out 7.2V (6x1.2V). Anyone else have these problems/concerns?

I previously had another off brand battery grip which died  and it had the problem that AAs always showed a full charge until the camera shut off so it may be that AA implementation in these grips is just not that great.

Canon EOS 600D (EOS Rebel T3i / EOS Kiss X5)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow