Fujifilm X100 Black Special Edition Refurbished - Broken on arrival!

Started Nov 16, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Bebrox
Contributing MemberPosts: 611Gear list
Like?
Fujifilm X100 Black Special Edition Refurbished - Broken on arrival!
Nov 16, 2012

I am gutted, I received my Refurbished X100 LE today from shop.fuji.co.uk.

I patiently let the battery charge up for more than 3hrs (until the led battery charge light went out), inserted the battery into the camera, powered it up, set the language to English at the first time start up prompt, chose the date format and clicked on the ok button. The camera was now dead!

I removed the battery for 5mins and put it back into the camera then powered it up. This time after I clicked ok for the Language prompt it powered off before I could reach the date/time format.

I have tried about 10 x but the camera just won't get past the language choice, I have tried with and without the SD card and various button combinations when powering it on.

I cannot believe that this 'Refurbished' camera doesn't even come on for me to take just one glorious photograph.

If anyone has any ideas please help.

I know that I am now going to have to start the returns process, it was their last one in stock too!

Fujifilm FinePix X100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow