Strange behaviour of X-E1 viewfinder

Started Nov 14, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
seukel
Regular MemberPosts: 456Gear list
Like?
Strange behaviour of X-E1 viewfinder
Nov 14, 2012

Yesterday my local photoshop received its first shipment of X-E1-kits (with the 18-55), so I could finally give it a try. Nice look and feeling of the camera all in all, but I was rather disappointed by the EVF. When autofocusing there was a short freeze when different lines (outlines of objects) in the scene became strangely "jagged" or pixelated. When the focus frame turned green the image became smooth and normal again. Moreoever, when panning with focus locked the picture moved in a wavelike, almost nauseating fashion. The salesman could not explain it, but said that this was probably just typical of this EVF, and that the EVF of the X-E1 was not as good as the one the X-Pro1. I had thought that it was the other way round.
Could this have something to do with the fact that the shop was illuminated by fluorescent light everywhere (it was already totally dark outside)? But then I guess the salespersons should have known about it. Or was it a bad copy? If not, the much acclaimed EVF of the X-E1 is really not that good after all.

Fujifilm X-E1 Fujifilm X-Pro1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow