T3i Viewfinder/Liveview discrepancy! Help!!!

Started Nov 13, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
TheyCallmeLamy
New MemberPosts: 16Gear list
Like?
T3i Viewfinder/Liveview discrepancy! Help!!!
Nov 13, 2012

Hey there!

While testing out my new Sigma 30mm 1.4 ex after it got back from calibration I noticed something strange on my T3i. While testing it around the house on a tripod i noticed that the center Autofocus dot and the center of the liveview 10x square are not even close. If I set focus on something exactly on the dot then switch to liveview, the spot I focused on is barely inside the upper left corner of the box. On the flip side of that, if I center my subject in the middle of the live view 10x box and go back over the viewfinder, my subject is way off the center af dot. Its not a matter of the camera moving as it on a sturdy tripod. I dont know what gives. Is this a camera issue that Canon may need to fix? How I found this out is i though my Sigma lens was still front focusing. It is while using viewfinder because what I just said. But using live view its sharp as heck and on the spot. What gives?? I'm annoyed!

 TheyCallmeLamy's gear list:TheyCallmeLamy's gear list
Canon EOS 600D Canon EF-S 15-85mm f/3.5-5.6 IS USM Canon EF 70-200mm f/4.0L USM Sigma 50mm F1.4 EX DG HSM Sigma 30mm F1.4 EX DC HSM +1 more
Canon EOS 600D (EOS Rebel T3i / EOS Kiss X5)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow