Some Questions for the More Experienced Users of the DP2M

Started Nov 11, 2012 | Discussions thread
Kendall Helmstetter Gelner
Forum ProPosts: 18,416Gear list
Like?
I have had that happen, not an issue with your camera
In reply to barjohn, Nov 11, 2012

barjohn wrote:

I have noticed that on occasion when I press the shutter release even though the shutter speed might be 1/125 it doesn't just go click-click. Instead it goes click-pause-count-click as if the shutter speed were 1sec. However, the image comes out like it was taken at 1/125th. Has anyone else experienced this behavior? Is it normal for it to do this on occasion? It appears to be random and even though it sounds like the shutter did not close for over a second the image is fine. Anyone have any idea what causes this and how to fix it? Is my camera defective?

I can confirm that happens, and it's not a two-second timer thing as some are surmising.

Instead as you say, the picture is taken right away and at the correct shutter speed, but it seems like the second click just comes a bit late (this is the physical sound and not the pretend shutter sound you can enable).

I don't think it's a flaw at all. I think it's something related to processing of the taken image, that whatever the second click is just gets held up by the camera doing its thing saving the image. I would not worry about it, your camera is not defective.

 Kendall Helmstetter Gelner's gear list:Kendall Helmstetter Gelner's gear list
Sigma 70-200mm F2.8 EX DG OS HSM Sigma 8-16mm F4.5-5.6 DC HSM Sigma 24-70mm F2.8 EX DG HSM Sigma 50-500mm F4.5-6.3 DG OS HSM Sigma 85mm F1.4 EX DG HSM +4 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow