Issue with Fotodiox dandelion adapter, Nikon mounted Sigma 10-20mm lens, and EOS 60D. No focus conf.

Started Nov 10, 2012 | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
keethantom
New MemberPosts: 1
Like?
Issue with Fotodiox dandelion adapter, Nikon mounted Sigma 10-20mm lens, and EOS 60D. No focus conf.
Nov 10, 2012

I purchased one of the below to use with my Nikon mount Sigma 10-20mm, and after trying almost everything I could find online, I cannot get the dandelion chip to work. My aperture still reads 00, and I can't get an AF confirmation. I'm wondering if it's because I'm doing something wrong, or if the chip just doesn't work.

Here is what I've tried so far:

  • Cleaning the contacts

  • Reseting the camera to factory settings

  • Updating my 60D's firmware to 1.1.1

  • Placing the adapter in the mount first, and then attaching the lens.

  • Placing adapter on the lens first and then into the mount.

  • Making sure the contacts line up.

Would anyone happen to know what the issue could possibly be?

Fotodiox Pro Lens Mount Adapter with Dandelion AF Focus Confirmation Chip, Nikon (Including G-Type) Lens to Canon EOS cameras, fits Canon EOS 1D, 1DS, Mark II, III, IV, 1DC, 1DX, D30, D60, 10D, 20D, 20DA, 30D, 40D, 50D, 60D, 60DA, 5D, Mark II, 7D, Rebel XT, XTi, XSi, T1, T1i, T2i, T3, T3i, T4, T4i, C300, C500http://fotodioxpro.com/index.php/fotodiox-pro-lens-mount-adapter-with-dandelion-af-focus-confirmation-chip-nikon-including-g-type-lens-to-canon-eos-cameras-fits-canon-eos-1d-1ds-mark-ii-iii-iv-5d-mark-ii-7d-10d-20d-30d-40d-50d-60d-digital-rebel-xt-xti-xs-xsi-t1i.html

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow