5D Mark 3 one week old DEAD!!!!! help please Locked

Started Oct 25, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
This thread is locked.
Canondog
New MemberPosts: 5
5D Mark 3 one week old DEAD!!!!! help please
Oct 25, 2012

Hi there. Im traveling outside the US and I have an ugly problem.  My company purchased 4 5D mk iii and 3 of them are dead! This is a once in a life time situation.

This is what happened. I purchased several 3rd party batteries online and took them with me last week. I charge them and kept them as backups. Yesterday I was using my last original Canon battery, and when I plugged this 7.4v 2600 mAh LP-E6, the camera went dead. it seemed strange to me so I plugged the same in the other camera and it did not turn on. I then charged an original and it did not work on the first two 5ds except on the 3rd. once i drained that battery, I plugged the 3rd party battery and the camera, flipped the switch, and ir turned on  for a split second and then it died.

I have a feeling that a fuse or something is dead. I went to a camera shop and they advised me to call Canon, when I called Canon, I was told that it can only be serviced in the USA. the closest place where it can be fixed is 100's of miles away. Im in Patagonia and I need to find a fix for this.

The camera shop here told me that if i can get the fuse ( in case that thats the problem) they will replace it. Thats a risk im willing to take.

ANY ADVICE OUT THERE!!!!

Also, if I can get a link to where I can buy this part it will help me a lot.

Ron

Canon EOS 5D Canon EOS 5D Mark III
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
LOLNew
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow