RX100: Corruption!

Started Oct 21, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Anders Lundgren
Regular MemberPosts: 245Gear list
Like?
RX100: Corruption!
Oct 21, 2012

Hello,

I'm rather pleased with my RX100. Big difference from lugging my heavy D700 around. The other night I brought the RX100 out for some night shooting. There was a drizzle, so the camera got a little bit wet. I'm aware that it has no weather sealing, but I think I took enough care.

When I got home, I couldn't watch some of the shots in display mode. I then put the card in my computer. To my horror I could see that about 30% of the files had corrupted file names with characters not allowed in a file name. I had quite a few folders from previous shoots on it too and some of those were corrupted as well as the newly added.  Most of them failed to show up in my photo browser, some did. Even though I changed the file name back to a valid one, the browser failed to read them. Also, some photos that came up were black with small stripes from the footage.

Now, I wonder:

1. Was the damp photo session to blame?

2. Did the card fail (Verbatim Premium SDHC Class 10 32 GB)?

3. Do I have a faulty camera?

Any input will be appreciated. Since this incident I've formattted the card and everything seams okay.

Regards,
Anders

 Anders Lundgren's gear list:Anders Lundgren's gear list
Sony RX100 Nikon D700 Fujifilm X-T1
Nikon D700 Sony RX100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
:-)New
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow