50D autofocus failing?

Started Oct 13, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
NotDavid New Member • Posts: 18
50D autofocus failing?

I've had a 50D for a few years and have been quite happy with it. However, lately I've noticed that autofocus seems to hunt and never quite lock on with the far left and right focus points, in less than ideal light situations at wide angle. In good light and high contrast conditions, it locks on as snappy as ever, but performance has definitely decreased in low light / low contrast situations.

I've noticed this with both my 15-85 and 17-40 f/4L at 15mm and 17mm. For comparison, my 5DII locks on in the same conditions without hesitation @ 17mm with the L lens. Longer focal lengths don't seem to be affected.

Has anyone had a similar experience with their camera? I was considering having everything cleaned at a local camera shop in hopes that it would fix the problem. Anyone have any thoughts? I was also messing around with Magic Lantern and a firmware update around the time I first noticed this, and was wondering if I messed anything up because of that...

Any feedback would be appreciated! Thanks!

 NotDavid's gear list:NotDavid's gear list
Olympus PEN E-PM2 Panasonic Lumix DMC-GH4 Panasonic Lumix G 20mm F1.7 ASPH Panasonic Lumix G 14mm F2.5 ASPH Panasonic Leica Summilux DG 25mm F1.4 +7 more
Canon EOS 50D Canon EOS 5D Mark II
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow