New forum system and Safari don't mix well. Any thoughts?

Started Oct 7, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
gollywop
Veteran MemberPosts: 5,624
Like?
New forum system and Safari don't mix well. Any thoughts?
Oct 7, 2012

I don't get it.  When I view images posted in this forum in Safari, they appear badly over saturated, particularly in the reds and greens, which begin to take on a neonish quality.  They look fine when viewed in Firefox.  And if I download the images and examine them in PS, they look like they do in Firefox, not like they do in Safari.

Now, you may just think there is something wrong with Safari or with the way Safari interacts with my monitor, but there is evidence that makes that hard to understand: when I examine images posted elsewhere on dPreview, such as in the Challenges or in the Sample Images, they look exactly the same when viewed in Safari as they do in FireFox.  It's only the forum images that have the issue.

And, this was not an issue with the old Forum system.  Forum images displayed properly in Safari.

Has anyone any idea what's happening?

[And please, don't tell me this is the wrong forum; it's not.  I already posted this issue on the Mac forum and it essentially died on the vine.  This is one of the few fora that is vibrant on most matters.]

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow