Bummed, but returning D600

Started Oct 7, 2012 | Discussions thread
RDMSguy
Junior MemberPosts: 47
Like?
Re: Bummed, but returning D600
In reply to jabilson007, Oct 7, 2012

jabilson007 wrote:

inasir1971 wrote:

It might be oil on the sensor - quite common on new bodies and easily cleaned by a store (or by yourself with the right gear).

I bought the cleaning kit the store recommended and followed their advice and the product instructions. It did not help. I am within the return time frame, so it is going back. I will get another though because I seriously like the camera. Thanks.

-- hide signature --

"If you can't say something nice...go **** yourself"
-unknown

What brand and type of cleaning kit did they sell you?

Your sensor needs a simple wet cleaning.

A few things to keep in mind.. If your going to continue with Nikon.. Chances are your going to get the same issue with any new body you buy. The first couple thousand clicks tend to be the worst for both oil and dust, but after that it's not a big deal.

I was scared the first time I did a wet cleaning for my D800. I didn't just have dust, but I had spots that looked to fall more in line excess oil deposits as well. I used an eclipse kit I purchased from amazon for 20 bucks. I watched some highly rated youtube videos showing how to use the sensor swabs, then did it myself. It ended up being fairly easy.

I'd get used to the concept of cleaning your sensor.. Sooner or later you will have to do it, or pay someone else to do it. Might as well start doing it now.

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
n/tNew
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow