S100 after 2nd repair

Started Sep 1, 2012 | Discussions thread
brianj
Forum ProPosts: 13,048Gear list
Like?
Re: Third time ?!?!?!?!?!
In reply to Jeff Wong illustration design, Sep 24, 2012

Jeff Wong illustration design wrote:

I am wondering if in this instance, the Lens Error is voltage related. I was getting errors this afternoon, and thought, "Let me change the battery." The camera fired back up (I will have to report back later to see if the errors cease, as the Lens Error was intermittent over the weekend, but frequent last night and just a few minutes ago when I was trying to take some pictures of a small sculpting job I'm working on). Fingers crossed. I am wondering if the camera lacks enough voltage to fully move the lens into position and if my batteries are showing a fuller charge than they are actually delivering (they've been in use about 10 months and may be building up internal resistance where a charge shows, but isn't delivering).

Not sure if this has ever been stated on the canon forum, but I have said it eleswhere. It is worth cleaning the battery and camera terminals with electrical cleaning fluid on a cotton bud periodically, and if you don't have any special electrical cleaner, something like wd40 etc will do.

Secondly, I always extend the lens barrel full, as in usually full zoom, then clean the outside of the barrels with a slippery cleaner like silicon furniture cleaner, this makes it much easier for the lens motor to move the lens and hense less current drawn from the battery.

These two actions will cure any lens problems that are not caused by something being broken in the lens assembly.

It really makes one scared to buy the S110 unfortunately.

Brian

 brianj's gear list:brianj's gear list
Canon PowerShot ELPH 330 HS
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow