Warning about Aperture 3.4 update

Started Sep 20, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Kendall Helmstetter Gelner
Forum ProPosts: 18,407Gear list
Like?
Warning about Aperture 3.4 update
Sep 20, 2012

Make sure you have a full backup of your Aperture library before you try to run 3.4.

When I ran, it wanted to upgrade my database - it detected some kind of issue in the database, and said it was closing to re-launch to do a rebuild.

Well, that re-launch crashed. Then I tried to do a re-build, and that crashed... after a few similar tries, I reverted to a full cloned copy of my Aperture database (happily backed up just before I upgraded Aperture). Then, I copied the older Aperture from a backup drive (you could also get it off Time Machine, but my TM drive had decided to die just days earlier and I had not replaced it yet).

After restoring the cloned copy of my library and the older Aperture, Aperture runs fine again. My new plan is to re-build the database using the older Aperture, then after that run the new Aperture again which hopefully will find the database totally clean and requiring no further work beyond the 3.4 update stuff it had planned to do.

Message: Always fully backup Aperture library before any Aperture update.

 Kendall Helmstetter Gelner's gear list:Kendall Helmstetter Gelner's gear list
Sigma 70-200mm F2.8 EX DG OS HSM Sigma 8-16mm F4.5-5.6 DC HSM Sigma 24-70mm F2.8 EX DG HSM Sigma 50-500mm F4.5-6.3 DG OS HSM Sigma 85mm F1.4 EX DG HSM +4 more
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow