Refurb E-PL3 - dead pixel, dirty sensor?

Started Sep 10, 2012 | Discussions thread
phototransformations
Senior MemberPosts: 2,607Gear list
Like?
Re: Refurb E-PL3 - dead pixel, dirty sensor?
In reply to DaveInPhilly, Sep 11, 2012

No, buy the SensorKlear Pen. Same sort of tip but small, flat, and triangular. Try to sweep over the dust at a slight angle so the tip can dislodge it. If it moves but is still on the sensor, blow it off with a Rocket blower. But first shoot the sky at f16 and see if it shows in your images as a roundish shadow. If not, leave it alone as it's not a problem.

DaveInPhilly wrote:

Thank you for your suggestions. I did finally figure out how to use the Pixel Mapping feature. After I ran that I could not find the spot on the LCD screen (which gives me a good deal of hope), but I haven't looked at any of the pictures on my computer monitor yet, so I can't be certain it did the trick just yet.

As far as cleaning the sensor (if that will be necessary), would this work:

http://www.amazon.com/dp/B007G5NNOW/ref=pe_175190_21431760_M3C_SC_dp_3

Or do I need one specifically designed to clean the senor? I ask because I already have this guy.

 phototransformations's gear list:phototransformations's gear list
Samsung TL500 Panasonic Lumix DMC-LX7 Panasonic Lumix DMC-G1 Panasonic Lumix DMC-G3 Panasonic Lumix G Vario 14-45mm F3.5-5.6 ASPH OIS +22 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow