7D Firmware v2.0.0 freezing problem confirmed by Canon: Proof

Started Aug 31, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
AC1
AC1
Senior MemberPosts: 1,163Gear list
Like?
7D Firmware v2.0.0 freezing problem confirmed by Canon: Proof
Aug 31, 2012

Just picked up my error-prone 7D from Canon NZ.

Followers of this other thread:

http://forums.dpreview.com/forums/readflat.asp?forum=1019&thread=42246370

will know that I've been experiencing 2 types of problems:

1. Freezing. This started immediately post upgrading to firmware v2.0.0.

2. Error 30s & 40s. This started last weekend approx. 2 weeks after upgrade.

I'm not gonna repeat the whole history again here but in short a small number of us have been experiencing freezing and were convinced there was a problem with v2.0.0 whilst a larger number have experienced no problems. And some of the 'no problems' camp have denied there is any issue and even gone as far as blaming everything else under the sun for our freezing problems including our installation procedure or our imagination.

The attached service invoice (see bottom window 'Comments') confirms what I was told verbally by Canon 2 days ago. Namely that my Err 30s & 40s were caused by a lose screw which they have fixed. In other words unrelated to the firmware but just a bad coincidence of timing.

But they did confirm that the freezing IS caused by the v2.0.0 firmware.

Canon NZ tell me that from their discussions with Canon Australia and Canon HO, they are the first in the world to confirm the firmware problem globally and that my 7D is the body they have done that with.

Canon NZ also tell me that they believe an update/fix to v2.0.0 will be released around mid-Sep.

Canon NZ have also removed the firmware v2.0.0 from their website - I don't kow if other countries have followed suit yet (or if they will).

Canon NZ offered to keep my 7D and install the firmware fix when it arrives but I wanted to have it back to use and will disable APO as a temporary workaround.

Based on my experience, my advice to others is this:

  • If you have not yet upgraded your 7D to v2.0.0 then don't. Sit tight until the fixed version arrives later in Sep.

  • If you have upgraded to v2.0.0 disable APO to avoid potential problems. And obviously install the firmware fix when that arrives. That is obviously what I'll be doing.

Finally, I should acknowledge Canon NZ's service support which has been first class since I first flagged the problem with them. They have communicated openly and frequently with me and been friendly and approachable. It certainly helps that I live nearby and can meet them face-to-face to discuss things. This has worked to both my benefit and Canon's. A great service story. As you will see from the invoice, whilst they could have charged me for fixing the lose screw (unrelated to firmware problem) they chose not to as a gesture of good faith, given the others problems I've experienced.

 AC1's gear list:AC1's gear list
Canon PowerShot S95 Canon EOS 7D Canon EF 50mm f/1.4 USM Canon EF-S 10-22mm f/3.5-4.5 USM Canon EF-S 15-85mm f/3.5-5.6 IS USM +2 more
Canon EOS 7D Nikon 1 V2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow