Ever sent anything to Sigma for repair?

Started Aug 25, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Shield3
Senior MemberPosts: 2,440Gear list
Like?
Ever sent anything to Sigma for repair?
Aug 25, 2012

Just curious to hear your stories.

Right now I have several lenses; the Sony 16-50, Tamron 70-300 USD, Sigma 30mm F/1.4, Sigma 50mm F/1.4.

NONE of these lenses need AF micro adjust in any way. However my recently purchased Sigma Outlet 50-150 needs around a +9 to adjust for the front focusing issue. Normally I would just leave it set to that and not worry about it.

However, if I set that lens to +9 and then attach my Sigma 50mm F/1.4, the A77 thinks that the 50-150 is attached due to the similar lens ID and also sets it to +9. So if I happen to forget, then all my shots with the 50 are backfocused slightly.

I have spoke to Sigma technical and they suggested I send in the lens plus my camera body - they told me about a week. I'm in Ohio.

Any horror stories about doing this? I just don't want to turn a minor inconvenience into something much worse.

Please advise,
Shawn

 Shield3's gear list:Shield3's gear list
Canon EOS 5D Mark III Canon EF 35mm f/1.4L USM Canon EF 85mm f/1.2L II USM Canon EF 135mm f/2.0L USM Canon EF 70-200mm f/2.8L IS II USM +2 more
Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow