Oly 14-54mm works with E5 but not with E3 or other models???

Started Aug 22, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
quallsphoto
Regular MemberPosts: 171
Like?
Oly 14-54mm works with E5 but not with E3 or other models???
Aug 22, 2012

Have anyone ever encountered an Olympus 14-54mm f/2.8-3.5 Series I lens that worked perfectly with an E-5 body, but would not focus when mounted on older Olympus cameras?

I had an older 14-54mm zoom lens with focus issues. It would not consistently focus in autofocus nor manual mode. I often had to zoom all the way out, zoom back in, and then try to refocus, to get a lock on a subject. This consistently erratic behavior occurred during tests with 4 camera bodies: E-3, E-1, E-520, and E-500. Because of the focus issue, the spare lens hadn't been used in 2+ years, and I finally sold it last week.

The person that bought the "malfunctioning" lens mounted it on a new E-5 body . . . and reports that it FOCUSES PERFECTLY! At first, she was afraid that I had accidentally given her the wrong lens.

Has anyone experienced this with the 14-54mm Series I lens? Any guesses why it focuses fine on the E-5 body but not on an E-3 or other Oly bodies?? I understand the CDAF vs PDAF issues with micro-4/3 bodies, but what could have occurred here?

http://www.quallsphotography.com

Olympus E-1 Olympus E-3 Olympus E-5 Olympus E-520
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow