40D - loud pop and now dead?

Started Aug 18, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Coderedpl
New MemberPosts: 9
Like?
40D - loud pop and now dead?
Aug 18, 2012

I'm new to this forum and I've been trying to find out what exactly happened to my 40D today.

I bought it used on craigslist a long time ago for a really good price, so obviously by now I do not have a warranty. Overall it wasn't use that much since I havent had the time to get deep into photography, and I'm just a learner.

This past Thursday I was out taking pictures and everything worked fine, both using my 50mm and the kit lense. All was good.

Today I swapped over the kit lense, it worked fine, turned on and all, gave it to my brother to snap some pics at an event he went to. He was able to get some shots in, then at some point he said he wanted to take a picture and there was a loud pop from the camera, it shut off and hasn't turned on since.

I've taken out both batteries, and the CF card and left it alone for a while. Put them back in and nothing. I know the battery was charged because I charged it the night before.

Reading and searching it seems as if its the main board that died. Does this seem right?

Anybody know what the cost of having that replaced and fixed is? vs another used camera?

I'm actually starting an intro to photography class in 2 weeks and i really need the camera
Any ideas?

Canon EOS 40D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow