RX100 -- easy playback on could be fixed in FW upgrade?

Started Aug 18, 2012 | Discussions thread
WT21
Veteran MemberPosts: 4,609Gear list
Like?
Re: Two different issues at play
In reply to The Skipper, Aug 18, 2012

I agree, but I think the simple fix is that the play button does not turn on the camera with a simple press, but requires press and hold for a couple of seconds. Right now, it's instant on, and there's no reason for that.

Your points, though, are valid. I think the fix is easy in FW.

The Skipper wrote:

I think the issue is not how recessed the "Play" button is - it doesn't seem better or worse than on similar cameras. IMO there are 3 issues:

1. In play mode, the camera will not time-out if it senses movement, potentially leading to complete battery drain if the button is accidentally pressed while walking around. This makes no sense to me - few people will view a photo for more than 2 minutes, & if one must, one can press some buttons to keep it on.

2. If a camera is already in Play mode, press the button a second time will extend the lens. Most other cameras require you to press the on/off button.

3. The above 2 issues by themselves, are just annoyances. But together it is dangerous. The button can be pressed accidentally the first time when walking around, and because it never times out, pressing it a second time can extend the lens in your pocket, potentially damaging the camera.

What is frustrating is that both of the above settings are not intuitive, and is in fact not something that you would even think to test for before taking a new camera on vacation.

 WT21's gear list:WT21's gear list
Sony RX100 Sony Alpha NEX-6 +1 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow