RX100 DEAD!!! Lens stuck, will not reset.

Started Aug 13, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
Ryanide Contributing Member • Posts: 542
RX100 DEAD!!! Lens stuck, will not reset.

First day in Venice Italy with my new RX100 and the camera is DEAD!!!

I shot about 300 photos with it. One time when powering off the lens got stuck and the screen said, Turn off power and turn back on. I did this and it was fine.

Later I tried to turn it off and the lens got stuck again half way. I tried removing the battery, and turning it off/on, pressing play to start it, even removed the battery and plugged in the power cord. Still nothing.

It partially opened, but not all the way. Then I get the power off/on message. When I power off, it closes almost all the way less than 1/16th still out (just a little) and it keeps trying to move it in and out.

I have left it off with no power or battery for several hours, still no luck. I think it is a gonner.

Any suggestions on how to fix it? Since I'm in Italy and leaving on a cruise I don't think I can get a replacement here or send it in right now.

Good thing I brought my other camera. This is really a bummer. I'm hoping someone knows some magic button sequence to reset it... ???

: (

 Ryanide's gear list:Ryanide's gear list
Canon EOS 5D Mark III Canon EOS-1D X Mark II Canon EF 24-70mm f/2.8L II USM Canon EF 100-400mm F4.5-5.6L IS II Canon EF 11-24mm F4L +6 more
Sony RX100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
Marti58 MOD
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow