Cannot Make AF-Assist Beam of 600EX-RT to work on 1Dx

Started Jul 31, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPreviousNext
Flat view
Thomas KP Lee
Thomas KP Lee Regular Member • Posts: 230
Cannot Make AF-Assist Beam of 600EX-RT to work on 1Dx

I got the 1Dx for a few days, and have problem to do AF in weak lighting (shooting with remote external flash lights without modeling light), so have to use a flashlight to illuminate the model to do focusing first, then turn off the flashlight to shoot.

In the past, can use the ST-E2 to get red light from it for AF assist, but ST-E2 does not work with 1Dx, so I bought the new flash 600EX-RT. However, after playing with with it for a whole night, I still cannot get the AF-Assist Beam from the 600EX-RT on the 1DX. I have made sure both camera and the flash have set to have the AF-Assist Beam turned on, however, I cannot see any red light came out, nor able to get AF on the camera ( was using EF 50 f1.2 L ) in dark (weak lighting). Anybody know how to get the AF-Assist Beam work from the 600EX-RT with 1DX? Please help!

 Thomas KP Lee's gear list:Thomas KP Lee's gear list
Sony Cyber-shot DSC-RX10 II Canon EOS-1D Mark IV Canon EOS-1D X Sony SLT-A99 Canon EOS 70D +7 more
Canon EOS-1D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow