Help! Problems on 5d Mark III?

Started Jul 29, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
derek86
New MemberPosts: 4
Like?
Help! Problems on 5d Mark III?
Jul 29, 2012

I have a brand new 5d Mark III that was new in box from an authorized retailer. However, I recently bought the 24-70 2.8L lens pre-owned on Amazon, and I've noticed what I would call lens flares on it frequently. I've only had the lens one day now though. Please take a look at this sample video I made in front of my couch just to give an idea of what I mean. There are two of them (four if you count the duplicates it creates) that float across the bottom as I pan in this video. Here's the link: http://www.youtube.com/watch?v=rfJVuo2trbY (View in 720p or 1080p please). Also, for some reason I am disappointed in the video quality of the 5d Mark iii, not so much in this nasty video, but in general when I'm outside taking shots. Do I need to check or modify some settings on the camera or is something wrong? I mean, I know my apartment isn't exactly the nicest looking thing to look at, however the lighting and colors should be better than this, shouldn't they? Mainly, when I pan left to right you get this blur of anything that is moving. Everything become illegible when there is motion in the video. You can even tell in my sample video that while panning, everything is a blur-out. Thoughts?

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow