New a57 owner/user lens issues

Started Jul 28, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
raywes
Contributing MemberPosts: 600Gear list
Like?
New a57 owner/user lens issues
Jul 28, 2012

As a new a57 owner almost a week now I have come to really really like this camera. However I noticed that my combo I use , a57/Tamron 18-270 pzd, does not give me clear/focused pics at zoom levels over 120mm and up to full zoom. No matter what I do and what setting/shutter speed/lighting I use, they are fuzzy and the images I get just do not look good.

I recently sent back my T4i as I was not happy with that cam but at least I was getting sharp pics at high zoom levels using the same exact 18-270 pzd combo. No good with this combo. Perhaps I am just too shaky and the IS built into Tamron's lens really benefited me as opposed to Sony's in body system OS.

I just purchased a Sony 18-250, and the moon pics handheld I just took at full 250mm zoom are almost crisp as can be at 1/40th of a sec? And this is even with the moon surrounded by haze and fog. Perhaps I just got a really bad copy of the Tamron 18-270 pzd. I have heard of this happening to people.

Here is what I just took at full 250mm, handheld tv mode, 1/40th sec, ISO 200, spot everything.
This has been cropped/resized for web use but otherwise is sooc.

Could the Sony 18-250/a57 combo be a that much better combo than the Tamron 18-270pzd combo?

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow