S100: Lens error after 7 months

Started Jul 15, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
gail
Forum ProPosts: 13,594Gear list
Like?
S100: Lens error after 7 months
Jul 15, 2012

Until yesterday, my s100 worked flawlessly! While I use it A LOT, I do treat it with lots of tender loving care. It's never been dropped and has never been exposed to extremes in weather.

I took some photos of my grand daughter yesterday, then shut the camera off. Tried to turn it on again about five minutes later to take some photos of my grandson who walked into the room. Got the black screen with dreaded lens error notice!

The camera shut down and the lens is stuck open.

Calling Canon Monday and sending it in for repair. In the interim, I'll be using my S90 and/or SD 700.

The serial number of my camera (“30xxxxxxxxxx”) falls within the range of a free repair.

SIGH !!!
--
My S100 Galleries ~ http://www.pbase.com/gailb/canon_s100
My Canon S100 Blog: http://www.digicamhelp.com/topics/camera-logs/canon-s100/

 gail's gear list:gail's gear list
Canon PowerShot SD700 IS Canon PowerShot S90 Canon PowerShot S100 Panasonic Lumix DMC-FZ200
Canon PowerShot S90
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
JeffNew
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow