7D not always turning on until I remove and replace battery.

Started Jul 1, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
PK62
Contributing MemberPosts: 834Gear list
Like?
7D not always turning on until I remove and replace battery.
Jul 1, 2012

I'll try to be clear with my question, but I need help. This is my second 7D that has issues with not turning on. The first one just wouldn't turn on at all so Adorama sent me a replacement. Now this one usually turns on OK, but sometimes only after I remove the battery and put in back in. I've tried everything I can think of, but was wondering if it could have anything to do with my 100-400mm lens being too tight in my camera bag. Being that this lens is a push pull style could it get jammed while the camera is in my bag and cause the camera to shut off or not come on the next time I try to turn it on?

Being that this is the second camera with the same problem, I'm somehow thinking it must be me. My lens works perfectly with my XSI, but there's more room in the bag with that camera. Any ideas?

It just seems odd that once I remove the battery and replace it, that it starts up. Sometimes it won't come on after auto shut down either...but again, if I remove the battery and put it back in, it turns on.
Should I just return this camera too, or try something else first?

 PK62's gear list:PK62's gear list
Canon EOS 6D Canon EOS 70D Canon EF-S 15-85mm f/3.5-5.6 IS USM Canon EF 17-40mm f/4.0L USM Canon EF 100-400mm f/4.5-5.6L IS USM +5 more
Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow