Need help please - A33 shutter release...

Started Jun 22, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
lonewolf69
Veteran MemberPosts: 3,345Gear list
Like?
Need help please - A33 shutter release...
Jun 22, 2012

Hi Folks,

About 1 year ago, I gifted a SHINY new A33 to my dad. But today, he's come back to me with the unit no longer working... When powered on and hitting the shutter release, the shutter will not open?

The green FOCUS indicator is solid and you can here/see the lens going through the motions of AF and then locking but the shutter will not release.

BIOS vers. 1.10 (debating whether to upgrade to 2.0 from SONY's UK Support site)

Using 11-18mm DT - Tried this lens on my A900 and put my CZ 24-70mm on the A33, lens is NOT an issue as both lenses fire the A900's shutter without issue and fails miserably on the A33
Already ran the factory reset multiple times as well
IF I can find my REMOTE shutter release, will try that next...

Any solutions/tips/advice would be greatly appreciated...

Thank you,

-Alex

-- hide signature --

-Alex

From the minds of Minolta to the imagination of Sony, Alpha, like no other.

http://www.pbase.com/lonewolf69

 lonewolf69's gear list:lonewolf69's gear list
Sony Alpha DSLR-A100 Sony Alpha DSLR-A700 Sony Alpha DSLR-A900 Sony SLT-A77 Sony 24-70mm F2.8 ZA SSM Carl Zeiss Vario-Sonnar T* +1 more
Sony SLT-A33
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow