Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Started Jun 20, 2012 | Discussions thread
Shop cameras & lenses ▾
Peter Galbavy Senior Member • Posts: 1,015
Re: Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Actually, it's Method 1 from the link posted you want - works for all Canon software I've come into contact with. My CDs are in boxes in the loft and have never been used.

-- hide signature --

Peter Galbavy

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow