X10 new sensor is noisy at low ISO?

Started Jun 20, 2012 | Discussions thread
a l b e r t
Senior MemberPosts: 1,265Gear list
Like?
Re: What is the fw version on sensor replaced X10?
In reply to PAUL TILL, Jun 21, 2012

Assuming my repair is not a dud, then I think Fuji should release a new firmware for the new sensor. The DR is likely to be different than the original sensor. This is going to affect the hw EXR mode. This seems to be what is happening with my X10.

I sent Fuji support a couple sample pics. Will call them tomorrow. I suspect I need to bring it in for a 2nd time.

BTW, they replaced the entire lens and sensor assembly. The new lens is noticeably softer on the right side at 28mm

PAUL TILL wrote:

a l b e r t wrote:

Yes I do. 1.03 boosted ISO to avoid the orb problem. So in some ways, it is better to use 1.02 as it doesn't boost ISO to avoid the orbs.

Keep it safe in case anyone else wants it.

I've asked Fuji why we need the 1.03 firmware if the new sensor is truly fixed, they are looking into it for me. It just seems odd to me as all it really does is raise the ISO to shorten the shutter speed to protect the highlights from orbing. If the new sensor is truly fixed we don't need this happening.

I also asked if it's safe to do what you have done and they said yes, although he said you will have a hard time finding the old firmware. (Didn't take me that long to find it :P).

 a l b e r t's gear list:a l b e r t's gear list
Fujifilm FinePix F31fd Fujifilm FinePix X100 Fujifilm X10 Nikon D3S Fujifilm X-E1 +7 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
(unknown member)
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow