Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Started Jun 20, 2012 | Discussions thread
Shop cameras & lenses ▾
denmarkdavis
denmarkdavis OP New Member • Posts: 2
Re: Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Thanks for the reply, but this is for installing DPP not the latest Eos Utility..

5D mk3 isn't recognised with 2.10 - I need 2.11 which is not available for download through Canon..

Really frustrating.

Reply   Reply with quote   Complain
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow