Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Started Jun 20, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
denmarkdavis New Member • Posts: 2
Driving me CRAZY! Need Eos Utility 2.11 for mk3...

Threw away the CDs expecting there to be an online download like usual.. No such luck. Could anyone send me their version so I can load some profiles onto my new cam?

Thanks

ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow