Bad experience with Fuji X100 repair in England

Started Jun 17, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
t_p_n
Forum MemberPosts: 74
Like?
Bad experience with Fuji X100 repair in England
Jun 17, 2012

Until recently I was a happy owner of a Fuji X100. In light of the reports on this forum about strap lug wear I sent my camera to the service in April due to minor wear. The strap lugs were replaced on the warranty at no cost to me.

But when I after 4 weeks received the camera again, there was dust on the sensor. I immediately returned the camera again forcleaning. After 3 weeks I got the camera back.

Now I noticed that the mechanism that switches between optical and electronic viewfinder was defective. When I switch between optical and electronic viewfinder approx. once every ten times, the viewfinder displays both the optical and electronic image at the same time.

I am soon going on vacation and cannot wait 3 to 4 weeks for repair. But after my vacation I will return the camera for repair again.

I live in Denmark and has been informed that the repairs are done in England. Are there others who have had similar bad experiences with repair in England?

Just for information, the store where I bought the camera has been very helpful. Last it was for repair I borrowed another Fuji X100, which unfortunately had exposure errors

-- hide signature --
Fujifilm FinePix X100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow