5Dii: covert hotpixel mapping ?

Started Jun 6, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Niels Hald Pedersen
New MemberPosts: 10
Like?
5Dii: covert hotpixel mapping ?
Jun 6, 2012

I just had a weird experience with my almost-brand-new 5Dii (bought from first owner, who went to the dark side after 3 month with Canon).

I love the camera, which is a tremendous upgrade from my (otherwise trusty) 5D.

But, alas, the 5Dii came complete with at glowing red hot pixel, very very clear at higher iso. Same coordinates in all shots.

I consulted the net, and found the following advice, which is a little strange:

"Put the camera in the mode for manual cleaning (wet/air), keep it there for 1 minute (with mirror up and shutter open). Then shut off the camera. No actual cleaning attempt should be done; neither is it necessary to remove the lens."

I did precisely that and the hot pixel disappeared. Completely.

Only meaningfull explanation is that the firmware makes a covert mapping out of hot pixels (and what else?) when physical sensor cleaning is attempted.

Anybody know something about this ?
Is it known behaviour ?

Firmware is 2.1.1

brgds
Niels

Canon EOS 5D Canon EOS 5D Mark II
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow