Slow overall response on 30D

Started Jun 6, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
M aarten
New MemberPosts: 2
Like?
Slow overall response on 30D
Jun 6, 2012

Does this issue sound familiar to anyone, and what was the matter?

I searched the web and found that others who had similar issues had it on (almost) new camera's and mostly shutter related. But not on a camera that is > 5 years old (shots taken about 30.000) and never had these issues.

Findings (sometimes it does, and sometimes it doesn’t):

- No shutter release/picture on full press of the shutter button. Does focus (quickly) on half press. But after seconds picture is still taken when button is hold.

- No shutter release/picture on full press of the shutter button. Holding button and got twin shutter release (in one shot mode).

- Half press and focus, then adjust exposure compensation by the wheel on the back. Adjustment is not made directly, but after a few seconds

(visible in top display that every step is taken in the camera . -1/3 => -2/3 => etc).
- Viewfinder information is lacking.

Looks to be appearing indifferent of:
- Lens used
- Battery used
- Battery level
- CF card used
- Free space on CF card
- Cleaned lens contacts
- MF/AF
- Amount of shots taken that day/hour/burst

Any ideas appreciated.

Canon EOS 30D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow