5D Mark III and autofocus issues

Started Jun 2, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Florian Wardell
Forum MemberPosts: 94
Like?
5D Mark III and autofocus issues
Jun 2, 2012

Hello!

So I sold all my lenses along with my 7D, and now have the 5D MIII and Canon's 50mm 1.4 prime.
I'm noticing some strange stuff.

  • The lens focuses beautifully on everything up close. I can use spot-AF and pinpoint a certain element on dollar note, will come up razor sharp, and if I use a large aperture, you can clearly see that the selected point is in the middle of the DoF.

  • The lens has more trouble focusing on things that are little further away, like 2 or 3 meters. If I adjust the autofocus, I need to be on +15/+20 for the lens to focus correctly on objects that are not close.

  • If I keep this +15/+20 adjustment, the camera will generally not focus correctly on close objects, but there are exceptions, 30% of the time focus will be good.

I'm a little puzzled. I would like to avoid calibration as I live in Cambodia, and I don't trust people here to handle the camera. Heard to many horror stories about the local shops.

Canon EOS 5D Canon EOS 5D Mark III Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow