Focusing issue with canon 7D and Canon EFS 60mm

Started May 17, 2012 | Discussions thread
Thorbard
Contributing MemberPosts: 672Gear list
Like?
Re: Focusing issue with canon 7D and Canon EFS 60mm
In reply to parmy, May 17, 2012

parmy wrote:

I am having a focusing problem with a Canon 7D and a Canon EFS 60mm lens. Sometimes the auto focusing works but most often it doesn't. The 7D body works with every other lens that I have and the Canon EFS 60mm lens works with my other cameras (550D and 400D). So, which has the problem, the 7D body or the Lens? I have reset the 7Ds to it's factory settings a couple of times, once it worked and the other time it didn't. I also followed this link http://blog.photoframd.com/...ips-auto-focus-not-working-check-your-settings/ and used the settings which also got the focusing working on one occasion but not the other times. So, I am baffled. If anyone has had a similar experience I would be most interested to hear about it.

Can you give some guidance on when the autofocus works and when not?

Does the camera confirm focus when the lens is not in focus? What focus mode is the camera set to?

Will the lens focus in live-view mode?

Generally I would guess that the 7D is not the problem as it is still focusing as usual with other lenses, but it would help to rule out some basic things.

 Thorbard's gear list:Thorbard's gear list
Canon PowerShot G15 Canon EOS 7D Canon EF 85mm f/1.8 USM Canon EF-S 15-85mm f/3.5-5.6 IS USM Sigma 18-200mm F3.5-6.3 DC OS HSM +1 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow