A57: Not that impressed thus far

Started Apr 21, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
konradsa
Regular MemberPosts: 163
Like?
A57: Not that impressed thus far
Apr 21, 2012

I am a beginner and this is my first SLR, but so far I am not that impressed. All my observations thus far are with the kit lens:

  • Image quality is not what I expected. For indoor pictures, the camera seems to mostly switch to ISO 3200 in auto mode. Images seem grainy and not very good then. Honestly, looks like my Panasonic FZ35 could take better pictures than that, and it mostly switches to ISO 800 in the same conditions. Maybe that is normal for an SLR, but I expected the IQ to be better. I could just be expecting too much.

  • Camera errors: Have been getting intermittent camera errors when I switched to fimware 1.02 (have another post about this on here). I formatted the memory card and reattached the lens, since then it seems to work, but they better not come back, otherwise I will return the camera.

  • Video quality: I took some low light videos in auto mode in my living room last night. The video was too dark to see anything. In manual mode when I opened the aperture a little more, it got better, but auto mode seemed way too dark.

I really wanted to love this camera, read all the reviews, and was waiting for it for weeks to come from Amazon. But so far, like I said, I am not that impressed. Maybe it's my inexperience with a DSLR, or maybe I was expecting too much of a difference to my Panasonic. But I will keep trying, and advice is appreciated.

Panasonic Lumix DMC-FZ35 (Lumix DMC-FZ38) Sony SLT-A57
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow