Remote shutter trigger not talking to camera body...

Started Apr 15, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
BlueTrain
Forum MemberPosts: 57
Like?
Remote shutter trigger not talking to camera body...
Apr 15, 2012

Hello

I have a cable shutter release for my 5D MkII which has worked fine for a year or so but now does not seem to be communicating with the camera.

It is not the official Canon trigger (N3?) - but a much cheaper third party version ( £20/$30). So no biggie to replace, but just wanted to check that its not something stupid i've done at my end like inadvertently changing a setting on the camera so that it does not recognise the incoming signal?

Reason I ask is that the actual remote still "seems" to work - the LCD screen works as normal, so does the green/red active light, the slider switch - it even still makes the annoying beeping noise when counting through the seconds.

But, it just doesn;t seem to register on the actual camera. So when the button is pressed the camera doesn't take the exposure even though everything on the remote says its activated the shutter switch.

Is there a setting I could have put the camera into so that it somehow ignores the remote? I've tried the camera in a variety of modes, long and short exposures... nothing. My guess is its the wire or the connector thats gone, but thought it worth checking before I replace.

Thanks for the advice
Tom

Canon EOS 5D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow