Bad luck or just Fuji, Fuji, Fuji?

Started Mar 31, 2012 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Style
Regular MemberPosts: 105
Like?
Bad luck or just Fuji, Fuji, Fuji?
Mar 31, 2012

This is my story: 5 weeks ago I exchanged my Fuji X10 for a X100. The orbs were too much for me. I was very pleased with the x100 untill I was struck by SAB. Fuji (Netherlands) offered to replace the lens unit.

Today after a very long wait (3 weeks) the X100 was returned to me. The delivery was accompanied by apologies for the inconvenience and an overview of what was checked and repaired. The new firmware was installed aswell. I was delighted to have my x100 back in my hands. Good to go shooting again!

Outside the store, I took some test shots. It felt great ... until I pressed the play button to see the results... no response ... another time..no response… reset the X100… no response ... ? The whole row of buttons on the left side of the LCD did no longer respond. I returned it to the store within 30min. Hope that this sloppy repair will be corrected and won't take as long as it did the first time!!

Are there any other X100 users who have had this unsatisfactory experience with Fuji repair services? Or am I the exception and is this just my bad luck?

Fujifilm FinePix X100 Fujifilm X10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow